13:00:22 <bstinson> #startmeeting CBS/Infra
13:00:22 <centbot> Meeting started Mon Oct 20 13:00:22 2014 UTC.  The chair is bstinson. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:22 <centbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:00:57 <imcleod> .hellomynameis imcleod
13:01:00 <bstinson> #chairs kbsingh alphacc Arrfab MerlinTHP
13:01:13 <bstinson> #chair kbsingh alphacc Arrfab MerlinTHP
13:01:13 <centbot> Current chairs: Arrfab MerlinTHP alphacc bstinson kbsingh
13:01:19 <bstinson> hi imcleod
13:01:22 <bstinson> and kbsingh
13:01:27 <imcleod> Hey bstinson and all
13:01:28 <MerlinTHP> Oooh
13:01:30 <MerlinTHP> It's that time
13:01:31 <MerlinTHP> Hi
13:01:39 <bstinson> should be a short meeting
13:01:45 <bstinson> #topic Agenda
13:01:50 <bstinson> #info Topic: Status Updates
13:01:55 <bstinson> #info Topic: Open Floor
13:01:55 * MerlinTHP "copy run start"s so he doesn't forget
13:02:20 <bstinson> #topic Status Updates
13:03:17 <bstinson> #info next action for Centpkg is to get with MerlinTHP about starting on the lookaside script
13:03:47 <MerlinTHP> OK, we can talk about that this week :)
13:05:17 <bstinson> MerlinTHP: i think we both have access to the cbs-tools repo on git.c.o
13:05:33 <MerlinTHP> Regarding my actions from last week... I've started a requirements document, but it's still at the semi-random bullet point stage.
13:05:37 <MerlinTHP> Yep, I do :)
13:05:43 <Arrfab> bstinson: normally yes, I've given access to both of you to that git repo
13:06:06 <MerlinTHP> I still need to talk to kbsingh about ACL granularity
13:06:29 <MerlinTHP> I'll try and get the lookaside stuff sorted this week.
13:07:37 <MerlinTHP> That's my actions from last week, basically :)
13:08:29 <Arrfab> MerlinTHP: yeah, I was supposed to also work with on that requirements document, but poodle and 6.6 got in the way
13:08:59 <MerlinTHP> Mm :)
13:09:19 <MerlinTHP> I was going to look at it more last week, but there was unwatched TV on my DVR, sorry ;)
13:09:35 <bstinson> i should have a light week at work, ping me if you want a hacking partner
13:10:03 <MerlinTHP> Sure :)
13:10:38 <bstinson> kbsingh: can you look at http://bugs.centos.org/view.php?id=7649 and http://bugs.centos.org/view.php?id=7648 when you get a chance?
13:10:51 <bstinson> i should have one more repo request coming in for centos-packager
13:11:33 <kbsingh> bstinson: wilo tomorrow AM - am going to also try the gitblit upgrade then
13:11:43 <kbsingh> bstinson: the blocker there is really working out where the repos need to end up at
13:11:54 <kbsingh> they dont really fit into a SIG model
13:12:05 <kbsingh> so maybe right at the top level with centos-git-common ?
13:13:20 <bstinson> that would probably work, i was thinking for each project we keep 1 repo for the actual source and 1 in dist-git format to build through koji
13:13:39 <bstinson> other workflows are welcome
13:14:23 <kbsingh> how do you mean actual source and dist-git ?
13:14:49 <MerlinTHP> Think of it as dist-git vs upstream
13:14:56 <bstinson> taking centpkg for example, there is already https://git.centos.org/summary/?r=centpkg.git
13:15:11 <MerlinTHP> dist-git is spec + tarball, "actual source" is where the tarball comes from
13:15:27 <bstinson> indeed
13:15:33 <kbsingh> hum
13:15:48 <MerlinTHP> It just happens that in this call, it's all us
13:15:55 <kbsingh> this is something that came up the other day as well, i dont think we've actually got a plan or a procss for people who want to do dev work against git.centos.org
13:16:40 <bstinson> what trouble were they running into?
13:17:00 <kbsingh> lack of process :)
13:17:13 <bstinson> heh :)
13:17:15 <kbsingh> git.centos.org is setup to host rpms, thats about it
13:17:55 <kbsingh> for content that isnt in the rpm format, the sig's can setup their own repos, eg for tests or docs etc
13:18:08 <kbsingh> i guess in this case, we can do something similar
13:18:29 <kbsingh> but its worth having a wider conversation on the centos-devel list a bit, so we make sure that a chunk of people are aware of this
13:19:13 <bstinson> is the plan to have separate projects for them to put those in?
13:21:31 <kbsingh> bstinson: i think thats just it - there is no plan.
13:21:55 <kbsingh> bstinson: what i said up there, was mostly meant to be for tests / docs - i dont think we actually hve a plan for a development git repo
13:22:16 <kbsingh> one challenge will be the branch naming, even if its a dev git repo, it will still limit you to the signame branch
13:22:41 <kbsingh> if we need to have repo's that dont restrict people to this ( which would make sense fro dev git repos ) - then i will need to go do some work at the backend
13:24:07 <bstinson> another option would be to spin off dev/tests/docs someplace else and do rpms-only in git.c.o
13:24:12 <bstinson> of course that would be a lot of extra work
13:28:17 <bstinson> kbsingh: would it help if I sent out an informal poll to the list, asking about preferred workflow?
13:28:41 <kbsingh> where would the someplace else be ?
13:29:35 <bstinson> that would be another machine somewhere, analogous to fedorahosted.org
13:30:12 <kbsingh> bstinson: thats an interesting though
13:30:45 <kbsingh> somedays, i can type - today is not one of those days
13:30:53 <mikem> centoshosted++
13:31:11 <kbsingh> bstinson: i think we can solve this by just having /rpms/ as a project be the dist-git stuff, and let everything else be in the other projects
13:31:34 <Evolution> the downside with doing a 'centoshosted' is that to some extent fedora's had failure with that
13:31:40 <kbsingh> mikem: I'm thinking that its going to be another piece of infra to maintain
13:31:43 <Evolution> fedorahosted isn't exactly winning.
13:32:05 <bstinson> kbsingh: that makes sense too
13:32:20 <mikem> kbsingh, yeah, otoh I think we discussed this before and folks suggested that github could just be used instead
13:32:30 <kbsingh> mikem: yeah
13:32:47 <MerlinTHP> as a project, centos seems a lot less allergic to github than fedora is
13:32:49 <kbsingh> i beleve we have a github.com/centosproject/ as well - we might be able to reuse that for adhoc upstreams
13:33:27 <mikem> kbsingh, doesn't have to be a different server. could be a different topdir/project on git.c.o
13:34:35 <mikem> but, while gitblit is pretty nice, github is probably nicer for folks working on projects
13:35:21 <kbsingh> yeah, the biggest win with github is someone else gets to run the signup and merge-req process
13:35:34 <MerlinTHP> :)
13:35:41 <kbsingh> bstinson: i think we can thrash out a solution, fairly quickly, but i dont think we should do that here.
13:35:57 <bstinson> sure, to the list
13:35:58 <kbsingh> its a pretty big deal and i think it would be best if we moved this specific item to the centos-devel list and work it there
13:37:14 <bstinson> kbsingh: did you want me to write something up, or were you going to send that out?
13:39:11 <kbsingh> sure, why dont you go ahead and send something in
13:40:14 <bstinson> #action bstinson will write up a discussion item on centos-devel about dev work on ad-hoc upstreams
13:40:24 <bstinson> #topic Open Floor
13:40:39 <bstinson> this has all been pretty much open floor :) but what else?
13:40:46 <MerlinTHP> Nothing else from me
13:41:17 <kbsingh> there was an issue on building from git.centos.org - did that get looked into ?
13:41:37 <kbsingh> i think gwd sent off ( requested! ) a build from rpms/xen.git - but it failed to show up in cbs
13:45:25 <bstinson> was there a bug filed?
13:45:39 <MerlinTHP> ISTR the build failed with a "can't find spec file" error
13:45:48 <MerlinTHP> Not sure of alphacc got a chance to look at it
13:45:52 <MerlinTHP> *if
13:48:04 <Evolution> MerlinTHP: would you be offended if I asked about auth?
13:48:16 <MerlinTHP> Not at all
13:48:24 <Evolution> in that case... auth?
13:48:28 <MerlinTHP> I was watching tv last week, though ;)
13:48:37 <MerlinTHP> Sorry, I was being slack last week.
13:48:44 <imcleod> I have a minor open floor request
13:48:49 <MerlinTHP> shoot
13:49:01 <imcleod> Could we get Colin Walters' CBS access sorted out: http://bugs.centos.org/view.php?id=7699
13:49:10 <imcleod> For Atomic SIG work.
13:49:11 <imcleod> :-)
13:50:38 <kbsingh> imcleod: given that the git.c.o -> cbs integration stuff isnt working quite yet, is there much value there ?
13:50:45 <kbsingh> imcleod: i guess he could hit scratch builds
13:51:28 <imcleod> kbsingh: My understanding is that cbs will currently allow tagged non-scratch builds from directly uploaded SRPMS.  Appreciate this is not ideal but it at least starts getting us Atomic content built in a public context.
13:51:50 <imcleod> kbsingh: I have my account and was going to start trying to create a stream of RPM builds.  Colin has offered to participate as well.
13:52:16 <imcleod> kbsingh: We will, of course, move to git.c.o ASAP.
13:53:04 <kbsingh> ok, works for me
13:53:12 <imcleod> kbsingh: Cool.
13:53:15 <bstinson> this goes to alphacc?
13:53:28 <Evolution> iirc MerlinTHP should have rights as well.
13:53:32 <kbsingh> yea, I'll sync with him once he is back on the right side of the pond
13:53:40 <MerlinTHP> what eh banana, not yet
13:53:50 <MerlinTHP> On the todo list for this week, I believe.
13:53:55 <Evolution> ah, okay
13:53:56 <Arrfab> Evolution: not that I'm aware if
13:54:39 <bstinson> what else for open floor?
13:54:52 <kbsingh> imcleod: ETA is going to be a few days on that req.
13:55:03 <imcleod> kbsingh: OK.
13:55:23 <imcleod> Me again: http://bugs.centos.org/view.php?id=7685 - Enabling koji image building features
13:55:52 <imcleod> Depending on the precise version of koji in use in the CBS, this may be as simple as adding the Image Factory packages to the lone koji builder and firing up libvirtd.
13:56:59 <alphacc> imcleod: we didn't have time to look at this one. sorry. I'll try to sort that out this week.
13:57:24 <imcleod> alphacc: No worries, just wanted to reaffirm my interest in it.  Also, I can assist with details, as I helped implement the feature in koji.
13:57:34 <imcleod> alphacc: Thanks!
13:58:06 <alphacc> imcleod: I'll drop a msg when I start
13:58:21 <imcleod> alphacc: Cheers.
13:59:11 <bstinson> great! if there's nothing else, i'll be closing the meeting in 1 minute
14:00:20 <bstinson> #endmeeting