14:06:57 <sbonazzo> #startmeeting Virt SIG
14:06:57 <centbot> Meeting started Tue Jan 13 14:06:57 2015 UTC.  The chair is sbonazzo. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:06:57 <centbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:07:06 <sbonazzo> #chairs gwd
14:07:10 <sbonazzo> #chair gwd
14:07:10 <centbot> Current chairs: gwd sbonazzo
14:07:20 <sbonazzo> chair  lars_kurth
14:07:26 <sbonazzo> #chair  lars_kurth
14:07:26 <centbot> Current chairs: gwd lars_kurth sbonazzo
14:07:39 <sbonazzo> #chair lars_kurth
14:07:39 <centbot> Current chairs: gwd lars_kurth sbonazzo
14:07:41 * dcaro|mtg here
14:07:43 * gwd should really learn how to use these things
14:07:47 <lars_kurth> me too
14:07:53 <sbonazzo> #chair dcaro|mtg
14:07:53 <centbot> Current chairs: dcaro|mtg gwd lars_kurth sbonazzo
14:08:05 <sbonazzo> #topic Agenda
14:08:11 <jzb> kbsingh: I'm supposed to meet with vbatts tonight - would tomorrow morning work?
14:08:16 <gwd> For the meeting minutes: OK; well, the Xen 4.4.1 rpms + libvirt 1.2.x (10?) have been in the repo
14:08:17 <gwd> since mid-december, and mostly there are positive things to say about it
14:08:20 <sbonazzo> #info Xen update
14:08:26 <sbonazzo> #info docker update
14:08:34 <sbonazzo> #info oVirt update
14:08:40 <sbonazzo> #info FOSDEM
14:08:46 <sbonazzo> #info other topics
14:09:01 <sbonazzo> #topic Xen update
14:09:36 <sbonazzo> #info Xen 4.4.1 rpms + libvirt 1.2.x (10?) have been in the repo since mid-december, and mostly there are positive things to say about it
14:09:37 <kbsingh> jzb: sure, sooner better.
14:10:31 <gwd> pasik: But is it the case that the virt-manager that comes with CentOS won't work with libvirt-libxl?
14:10:41 <gwd> er, CentOS 6
14:10:44 <kbsingh> we have a manual sign process in place, so are we then saying its ok to sign and push those into xen4rpms repo in production ?
14:11:06 <kbsingh> gwd: is that libvirt issue resolved with a rebuild of the libvirt in the repo ?
14:11:12 <kbsingh> erm, the virt-manager issue
14:11:37 <gwd> kbsingh: I think hughesjr and pasik were saying no.
14:11:44 <pasik> gwd: uhm, i haven't actually tried libvirt with libxl yet
14:12:10 <pasik> gwd: the 1.2.x version
14:12:21 <pasik> gwd: it should work, but we need to try :)
14:12:22 <sbonazzo> #chair pasik
14:12:22 <centbot> Current chairs: dcaro|mtg gwd lars_kurth pasik sbonazzo
14:12:30 <gwd> One of the main issues is that libvirt isn't actually a hypervisor *abstraction* library; it's just a common hypervisor *communication* library.
14:12:38 <sbonazzo> #chair kbsingh
14:12:38 <centbot> Current chairs: dcaro|mtg gwd kbsingh lars_kurth pasik sbonazzo
14:12:56 <pasik> gwd: the old libvirt 0.10 with libxl, on xen 4.2, was totally unusable; it segfaulted on "everything" etc
14:13:02 <gwd> It doesn't attempt to hide the details of the underlying hypervisor.  So just because something works on KVM (or xen+xend) doesn't mean it will work with the other ones.
14:13:51 <kbsingh> ok, then let me rephrase my question : what is the process to adopt from here, that would get us the confidence to sign and release those rpms for 4.4.1 ?
14:14:35 <pasik> kbsingh: i've tested the 4.4.1 rpms with xm/xend, and they work OK
14:14:37 <gwd> So the main issue at the moment is that xend is build, but disabled by default.
14:14:41 <pasik> now we still need to do the libxl testing
14:14:52 <sbonazzo> looks like an action item to verify Xen 4.4.1 rpms + libvirt 1.2.x + libvirt-libxl right?
14:14:59 <pasik> sbonazzo: correct
14:15:13 <sbonazzo> pasik: are you going to test it?
14:15:27 <gwd> Which I think would be fine, except that, according to hughesjr, virt-manager in C6 doesn't work with libvirt 1.2.10+libxl.
14:15:29 <pasik> sbonazzo: i can do that, but others hopefully will do testing aswell :)
14:15:44 <kbsingh> gwd: was it working with the last xen 4.2 build we have in production release at the moment ?
14:16:02 <pasik> kbsingh: xen 4.2.5 + libvirt 0.10 + xm/xend + virt-manager works OK
14:16:09 <gwd> So we can either ship it as-is, and have virt-manager not work by default (i.e., you have to manually enable xend)
14:16:16 <gwd> Or we can try to fix the virt-manager issue somehow.
14:16:18 <sbonazzo> #action pasik and any other volunteer to verify Xen 4.4.1 rpms + libvirt 1.2.x + libvirt-libxl
14:16:30 <gwd> kbsingh: In 4.2, AIUI, libvirt+libxl basically didn't exist
14:16:48 <gwd> So 4.2, virt-manager, libxl, xend: works
14:16:49 <lars_kurth> #chair lsm5
14:16:49 <centbot> Current chairs: dcaro|mtg gwd kbsingh lars_kurth lsm5 pasik sbonazzo
14:16:52 <kbsingh> gwd: if xend was chkconfig enabled in the existing machine, the new xend will still be enabled by init
14:17:04 <gwd> Sorry -- 4.2, virt-manager, xend: works
14:17:09 <gwd> 4.2, virt-manager, libxl: broken
14:17:24 <kbsingh> if thats the only thing that needed to be done, we should be mostly ok for people updating from the 4.2 to 4.4
14:17:25 <gwd> 4.4: virt-manader, xend: works *if you manually enable xend*
14:17:36 <gwd> 4.4: virt-manager, libxl: doesn't work (or so I've heard)
14:17:47 <kbsingh> for people doing new installs, they need to enable xend ( we can live with that, and maybe just communicate it really well )
14:18:13 <kbsingh> for me the key is not breaking people's existing installs. and if were not doing that, the rest of it is just a communication exercise
14:18:20 <lars_kurth> can we enable xend in the install?
14:18:38 <gwd> lars_kurth: Yes, we can; but I'd rather try to start shifting people off xend if we can.
14:18:43 <lars_kurth> of course we do need to fix the libvirt issue going forward
14:18:46 <lars_kurth> gwd: agreed
14:18:48 <kbsingh> lars_kurth: yeah, it can be shipped in the rpm enabled by default - would that cause issues with the xl ?
14:18:49 <gwd> Since it's been removed in 4.5
14:19:14 <gwd> kbsingh: Not at all; xl in 4.4 will refuse to do anything that might cause problems if it sees that xend is running.
14:19:14 <kbsingh> iirc, xl used to complain about somethings if xend was running
14:19:22 <kbsingh> yes, that
14:20:15 <sbonazzo> #agreed people should start move off xend in 4.4 since it's been removed in 4.5
14:20:19 <gwd> The main thing is that we lose the opportunity for people to try xl while still having the option to fall back to xend.
14:20:24 <kbsingh> so, in summary : for people with an existing 4.2 install, who want to keep using virt-manager when moving to 4.4, they need to enable xend in init. for everyone else, including new installs, were all good
14:20:52 <lars_kurth> gwd, pasik: any idea what the 4.4 - virt-manager issue may be and how hard it would be to fix it?
14:20:54 <gwd> kbsingh: An upgrade won't disable xend, will it?
14:21:19 <kbsingh> will xm complain gracefully without breaking vm's etc - if someone yum updates without xend running at the end ? ( ie. are we going to break production machines without the user having a chance )
14:21:30 <pasik> lars_kurth: i guess we'll find out when we test it :)
14:21:47 <gwd> lars_kurth: Nope.  It might be something trivial, in which case we could just build our own version of virt-manager (as we're already doing for python-virtinst); or it might be really difficult, in which case blah.
14:22:28 <kbsingh> someone will need to take up the task of working out what the problem really is... i think thats step1
14:22:44 <lars_kurth> Agreed. Who is someone?
14:22:49 <gwd> kbsingh: xend is started with an initscript; so I think if you've got it enabled in 4.2, it will still run when you upgrade.
14:23:44 <gwd> kbsingh: Probably something to test. :-)
14:24:09 <pasik> yeah, if xend is enabled in chkconfig, i think it'll stay enabled in xen upgrade
14:24:52 <pasik> lars_kurth: i'm going to test xen 4.4 + libxl + libvirt + virt-manager; i can write some report to centos-virt about the issues i see
14:25:11 <gwd> Well, I can put it on my to-do list, but I'm writing some talks for FOSDEM and Linux Collab summit, so I won't have a huge amount of time to work on it.
14:25:26 <gwd> pasik: Thanks, that would be really helpful.
14:25:27 <pasik> and we can continue from there
14:25:39 <kbsingh> #action pasik to test xen 4.4 + libxl + libvirt + virt-manager amd report to virt-list
14:26:17 <sbonazzo> looks like another action item is testing upgrade path from 4.2
14:26:33 <lars_kurth> ack
14:26:34 <gwd> But we can agree, I guess, that we want virt-manager to work with a default install of C6; so that would mean either fixing virt-manager or having xend on by default.
14:27:49 <gwd> Fixing virt-manager would be better if we can, because falling back to xend won't be an option in the future.
14:27:58 <kbsingh> #action gwd to test the upgrade path from 4.2 to 4.4 ( xen ) and report to virt-list
14:28:19 <kbsingh> is this somthing that Darius might be able to look at ?
14:28:32 <kbsingh> or, Dario even
14:28:41 <kbsingh> ( given that he's looked at libvirt in the past )
14:29:09 <gwd> So when we go past 4.4, we'll have to either fix virt-manager or maintain separate versions for C6 and C7.
14:29:28 <gwd> dario> I can ask him if he has time, but I suspect the answer will be "no"...
14:30:00 <lars_kurth> We are going in circles.. How about we do the testing first. We have 30 mins and should cover oVirt and Docker
14:30:23 <kbsingh> yeah, lets test this - workout what the real problem is - it might just be a 2 line patch somewhere.
14:30:31 <gwd> Did I see lsm5 join?
14:30:42 <kbsingh> in the mean time, can we agree that if are able to close off the libivrt / virt-manager thing on email to the list, we are ok to sign and release these rpms ?
14:30:52 <gwd> kbsingh: Yes, I think so.
14:30:54 <kbsingh> it would be nice to not need to wait another 2 weeks for release
14:30:59 <pasik> agreed, xen 4.4 rpms look good
14:31:06 <kbsingh> cool
14:31:08 <lars_kurth> agreed
14:31:39 <pasik> should we try to build the xen 4.4 rpms for el7 aswell?
14:31:45 <pasik> there are xen 4.4 el7 spec files out there..
14:31:57 <kbsingh> sure, why not.
14:32:08 <kbsingh> how about kernel ?
14:32:26 <pasik> i guess we could start with the same 3.10 (xen) kernel as is used on el6
14:32:37 <kbsingh> ok
14:32:37 <sbonazzo> #agreed on releasing xen 4.4 rpms if able to close off the libivrt / virt-manager issues on email to the list
14:32:41 <gwd> Would that work?  What's the kernel for C7?
14:32:51 <pasik> gwd: stock kernel in c7 is 3.10
14:33:03 <pasik> gwd: (with backports from later kernels)
14:33:28 <kbsingh> should we move to ovirt ?
14:33:35 <gwd> Right -- so using the c6 x4c kernel might actually work.
14:33:43 <lars_kurth> Yes
14:33:43 <pasik> gwd: yep
14:33:44 <gwd> OK, ovirt. :-)
14:33:49 <sbonazzo> #topic oVirt updates
14:33:53 <kbsingh> #topic ovirt status for Virt SIG
14:34:04 <kbsingh> haha, we have 2 ovirt topics, double the update
14:34:09 <sbonazzo> :-)
14:34:17 <kbsingh> I'll let you do the meetbot updates from here
14:34:23 <lsm5> gwd: here
14:34:28 <sbonazzo> we're near to release 3.5.1 RC (scheduled for tomorrow on ovirt repositories
14:34:52 <sbonazzo> #info oVirt 3.5.1 RC scheduled for Wed 14th Jan
14:35:04 <gwd> sbonazzo: You mean the upstream release?
14:35:04 <sbonazzo> we left before Xmas with http://bugs.centos.org/view.php?id=8004 open
14:35:08 <sbonazzo> gwd yep
14:35:36 <sbonazzo> no changes on the bug since
14:35:47 <sbonazzo> anybody working on it?
14:36:08 <dcaro|mtg> should we ping anyone in specific?
14:36:13 <lars_kurth> we acked; so this is one for kbsingh (and team)
14:36:33 <gwd> It's assigned to kbsingh , so maybe we should ping him. :-)
14:36:41 <sbonazzo> #action kbsingh to finalize  http://bugs.centos.org/view.php?id=8004
14:36:49 <kbsingh> for the wiki access, the req needs to go via the centos-docs list
14:37:09 <kbsingh> for the buildsystem this bug is filed agained the wrong category, noone has looked at it due to that
14:37:32 <sbonazzo> #action dcaro|mtg and sbonazzo to request wiki access using centos-docs list
14:37:47 <kbsingh> can you file the req against project: buildsystem and category: community buildsystem
14:37:54 <kbsingh> i cant move a bug between projects.
14:38:22 <kbsingh> actually, i can
14:38:24 <kbsingh> doing that now
14:38:38 <sbonazzo> kbsingh: thanks
14:38:43 <dcaro|mtg> kbsingh: thanks :)
14:39:03 <kbsingh> also, this is for sbonazzo - dcaro|mtg do you want access as well ? will need your own ticket
14:39:10 <kbsingh> otherway around, this is for dcaro|mtg
14:39:39 <sbonazzo> #action sbonazzo to fill a separate request against project: buildsystem and category: community buildsystem
14:39:45 <kbsingh> sbonazzo: do you need buildsys access as well ? if so, file a bug report and let me know what the number is - i can circle back with alphacc and get them done for you
14:39:54 <kbsingh> cool.
14:40:02 <kbsingh> so, are you really only going to import 3 rpms ?
14:40:14 <kbsingh> ovirt, ovirt-node, ovirt-live
14:40:30 <sbonazzo> kbsingh: well no... ovirt is a large project with several rpms
14:40:43 <kbsingh> ok
14:40:51 <gwd> I thought to begin with the priority was rebuilding qemu-kvm, right?
14:40:58 <gwd> (I forget the package name for that one...)
14:40:58 <sbonazzo> gwd: right
14:41:03 <kbsingh> so you will need anything/everything that is required, but not already in the distro and not already in the virt repos
14:41:37 <sbonazzo> kbsingh: yep. what if a package is in epel and not in centos / sig ?
14:41:43 <gwd> kbsingh: I think the thing they cared about most was just re-building the base centos qemu-kvm repo with one feature enabled.
14:41:46 <kbsingh> you need to import it - we dont/cant rely on epel
14:42:17 <sbonazzo> #info ovirt dependencies in epel repositories must be imported in centos virt repo
14:42:31 <kbsingh> are any of you guys at Fosdem ( its a trick question )
14:42:49 * gwd will be in the US dealing with a family issue
14:43:00 <lars_kurth> lars_kurth will be there
14:43:11 <sbonazzo> kbsingh: I won't be there but someone in ovirt team will be
14:43:15 <kbsingh> if so, http://wiki.centos.org/Events/Fosdem2015 bottom of page - there is a EPEL / CentOS meeting planned - its starting to get large, but projects like RDO and Ovirt who need components from EPEL reallyt -should- come
14:43:25 <kbsingh> the aim is to try and workout someway to not need to duplicate hundreds of rpms
14:44:41 <sbonazzo> kbsingh: looks like a nice target. maybe eedri may join
14:45:13 <kbsingh> sbonazzo: ask them to get in touch with me - the venue might change, and i will only be in touch with people who i know are coming
14:45:24 <kbsingh> do we need anything else from ovirt ? can we move to docker and lsm5 ?
14:45:30 <lars_kurth> lsm5: how much time do you need? (conscious of time)
14:45:37 <lsm5> not much
14:45:41 <sbonazzo> kbsingh: that's all from my side, dcaro|mtg?
14:46:01 <lsm5> docker still on 1.4.1 ..though there's an issue with /.docker for which I'll be pushing a patched build today
14:46:09 <lsm5> that's pretty much it ^
14:46:24 <lsm5> ohh will also build registry 0.9.1 soon
14:46:39 <sbonazzo> #action sbonazzo to ask ovirt people going to fosdem to get in touch with kbsingh
14:46:41 <gwd> Is that still only in virt7-testing, or has that / can that be manually signed soon?
14:47:20 <dcaro|mtg> sbonazzo: once we have the rights I'm sure we'll find more issues, but until that's all :)
14:47:46 <sbonazzo> #topic docker updates
14:48:45 <sbonazzo> #info docker still on 1.4.1, a new build will be issued today
14:49:00 <sbonazzo> #info registry 0.9.1 will be built soon
14:49:46 <lars_kurth> Any actions?
14:50:46 <lars_kurth> Anything else re docker?
14:50:49 <gwd> kbsingh: Any updates BTW on the CBS?  And/or, can we start manually signing things like docker, ovirt, &c?
14:51:31 <kbsingh> so, couple of things
14:51:45 <lsm5> that's all
14:51:49 <kbsingh> 1) git repo layouts are more of less done, I have another days worth of work to get over the fence, planning on doing that this friday
14:51:52 <lsm5> gwd: it's in virt7-testing
14:52:02 <kbsingh> 2) once that is done, we can get binary upload very quickly, for the lookaside cache stuff
14:52:30 <sbonazzo> #topic CSB updates
14:52:34 <kbsingh> w.r.t signing things, we have keys and can manually do things - alphacc is investigating the fedora automation around sigul as well, but even if that takes time, we can start signing things right away
14:53:01 <kbsingh> what we dont have at the moment is a nice clean interface to sign and push stuff notify from ( other than someone having to email me or ping me etc ) - so longer term we do need an automation layer
14:53:12 <kbsingh> end of update :)
14:53:43 <lars_kurth> Should we move on to FOSDEM, if there is anything to discuss?
14:53:46 <sbonazzo> #info git repo layouts are more of less done, kbsingh has another days worth of work to get over the fence, planning on doing that this friday
14:53:57 <sbonazzo> #info once that is done, we can get binary upload very quickly, for the lookaside cache stuff
14:54:22 <sbonazzo> #info we have keys and can manually sign rpms
14:54:35 <sbonazzo> #info alphacc is investigating the fedora automation around sigul as well
14:54:38 <kbsingh> w.r.t fosdem - we have 2 tables there, do we want to push any virt sig message from there ?
14:54:40 <sbonazzo> #topic FOSDEM
14:55:12 <gwd> kbsingh: OK; so should we do a beta of lsm5's docker packages, and then get them signed and pushed into the production repo?
14:55:19 <gwd> (Sorry for the slow response)
14:55:27 <kbsingh> gwd: can do
14:55:56 <gwd> Who should be the contact point(s) for the manual process for now?
14:56:02 <kbsingh> lsm5: will you let me know once you have the docker stuff in place ( with the ./docker fix )
14:56:12 <kbsingh> gwd: i can sign things, so they need to come via me.
14:56:12 <lsm5> kbsingh: yup
14:56:27 <kbsingh> am trying not to get this group me larger tham me - otherwise it reduces the urgency for automating it past me :D
14:56:45 <gwd> Fair enough. :-)
14:57:42 <gwd> OK -- lsm5: Have we made any big announcements about docker for C7?
14:58:27 <gwd> lsm5: If we could get a quick how-to out, then we could declare your next update a "public beta", and then in 2 weeks (or something) push it to production.
15:00:01 <gwd> OK, sorry -- FOSDEM.
15:00:54 <lars_kurth> kbsingh: anything you wanted to raise? The only thing is that we have a 20 min slot to give an update of th eVIRT SIG
15:01:00 <kbsingh> sounds good to me - getting an announcement for Fosdem would rock
15:01:28 <kbsingh> lars_kurth: in the virt-devroom ?
15:01:53 <pasik> we could (hopefully) release xen 4.4 aswell
15:01:58 <kbsingh> yup
15:01:59 <pasik> announce
15:02:06 <lars_kurth> as gwd can't make it - I will give it. So if lsm5 and sbonazzo want to give me same material of what they are trying to achieve that would be great
15:02:10 <lsm5> gwd: big announcements...not that i know of
15:02:15 <lars_kurth> kbsingh: yes, in the Virt devroom
15:02:43 <kbsingh> ok, we can syncup on that and do something
15:02:48 <kbsingh> is this on Sat or Sun ?
15:02:58 <lars_kurth> https://fosdem.org/2015/schedule/event/immutable/
15:02:58 <lsm5> lars_kurth: gwd sorry what exactly are you looking for in a how-to other than install and startup instructions?
15:03:00 <lars_kurth> Sunday
15:03:09 <kbsingh> ok, thats best
15:03:21 <gwd> lsm5: Well you're driving the docker stuff ultimately, but it seems like making a bit of noise about how it's available, and having some instructions on how to test the virt7-testing stuff, would be a good idea.
15:03:23 <kbsingh> i need to rebase over into another call, but will readup backlog here.
15:03:47 <lsm5> gwd: ack, sure thing
15:04:03 <gwd> lsm5: I meant just step-by-step instructions for adding the virt7-testing repo.
15:04:24 <sbonazzo> lars_kurth: will try to prepare something and send it to you offline
15:04:55 <lars_kurth> We have 20 minutes overall for everything in the SIG. So keep it short. I would say a) What, Where you are at, asking for help, a few linkjs on how to get started
15:05:30 <lars_kurth> My email is lars.kurth@xenproject.org
15:06:03 <gwd> lars_kurth: FYI I pitched that talk as about how the CentOS SIGs are supposed to work in general, with the Virt SIG as an example, not as a "Virt SIG update".
15:07:03 <lars_kurth> OK. I don't see a fundamental conflict there
15:07:15 <lsm5> gwd: ack
15:07:36 <gwd> OK, anything else to talk about?
15:07:50 <lars_kurth> I think that's it
15:08:28 <gwd> Great, thanks everyone.
15:08:28 <gwd> sbonazzo: How do you end the meeting? :-)
15:08:35 <sbonazzo> #endmeeting