16:02:29 <jzb> #startmeeting CentOS Atomic SIG
16:02:29 <centbot> Meeting started Thu Jan 22 16:02:29 2015 UTC.  The chair is jzb. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:02:29 <centbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
16:02:47 <jzb> #chair jbrooks kbsingh Evolution imcleod
16:02:47 <centbot> Current chairs: Evolution imcleod jbrooks jzb kbsingh
16:02:59 <jzb> I don't see nzwulflin here
16:03:06 <jzb> who else have I missed?
16:04:00 <kbsingh> colin ?
16:04:04 <jzb> ahhhh
16:04:09 <jzb> #chair walters
16:04:09 <centbot> Current chairs: Evolution imcleod jbrooks jzb kbsingh walters
16:04:29 <jzb> OK
16:05:00 <jzb> imcleod: anything you'd like to report this week?
16:05:21 <imcleod> jzb: Hiya
16:05:51 <imcleod> jzb: I have made a few runs at building Vagrant and qcow2 images from the nightly content, thus far without success.  Am still working on root cause.
16:06:03 <imcleod> jzb: I'm generally upbeat about it, just need to find the time to find the problem.
16:06:25 <jzb> imcleod: anything we can do to help there?
16:06:56 <imcleod> jzb: I suspect not.
16:07:13 <jbrooks> imcleod, Is this through koji?
16:07:49 <imcleod> jbrooks: It is indeed.  One of the problems, unfortunately, is that when the build fails in koji, the screenshot we get is not helpful, because of some bug with the text output/screensaver.
16:08:00 <imcleod> jbrooks: SO I have been doing root cause on another machine using Factory directly.
16:08:11 <imcleod> jbrooks: But the needed bits are in the CBS koji and should work once we have this sorted.
16:08:21 <imcleod> jbrooks: I have used them to build non-Atomic images.
16:08:31 <imcleod> jbrooks: And if you want to fiddle with them, that would be fantastic.
16:08:41 <jbrooks> imcleod, if your steps are documented, yeah, I can fiddle w/ it
16:09:05 <imcleod> jbrooks: What I should probably do is verify that the issue can be duplicated using rpm-ostree-toolbox.  rangerpb would love it if I did that.
16:09:46 <kbsingh> fwiw, rpm-ostree-toolbox isnt a happy place st the moment either
16:10:08 * kbsingh will update when his turn comes
16:11:20 <jzb> imcleod: is that it on your update?
16:11:30 * jzb should remember to do "topic"
16:11:39 <imcleod> jzb: That is all for me, I think.
16:11:48 <jzb> imcleod: groovy, thanks
16:11:55 <jzb> #topic update from kbsingh
16:12:02 <jzb> kbsingh: it's your turn :-)
16:12:44 <kbsingh> so, we ran the nightly builds for a few days ( a week actually )
16:12:55 <kbsingh> for ostree repo, and the lorax tree's
16:13:39 <kbsingh> however, 2015.1-1.el7 seems to have an issue where it does not like being run from Cron anymore
16:14:02 <kbsingh> it fails to do chroot into the new filesystem its setting up, and i need to go look at that sometime
16:14:07 <jzb> kbsingh: that's rpm-ostree?
16:14:13 <kbsingh> ( this is background to my note to centos-devel list btw )
16:14:30 <kbsingh> jzb: yeah, well - ostree and ostree-toolbox, same ver, updated at the same time
16:14:37 <jzb> kbsingh: gotcha
16:15:01 <kbsingh> I spoke with walters about this at the time, and he had a look at logs etc - we fixed a bunch of other things, but were unable to resolve this specific issue
16:15:15 <kbsingh> works fine from cli, not so much from cron, so its almost certainly going to be an ENV issue
16:15:38 <jzb> kbsingh: so you're having to do it manually, then
16:15:43 <walters> kbsingh,  maybe selinux policy?
16:15:49 <kbsingh> need to find the time to go investigate a bit; in the mean time I've kicked builds manually a few times, so none running centos atomic host is exposed
16:15:55 <walters> any avc denials?
16:16:15 <jzb> kbsingh: thanks
16:16:21 <kbsingh> selinux is actually disabled on the host, i think the ostree-2014 builds needed it turned off
16:16:56 <kbsingh> that was 50% of my update
16:17:17 <kbsingh> the other 50% is that I've been pushing the atomic host builds at EC2, and now have AMI's in every region based on the December build
16:17:49 <kbsingh> whatever warts and bugs it comes with, its there - and fr the Jan 29th build, can we consider telling people about these ?
16:17:55 <kbsingh> we dont need to decide right now
16:18:21 <jzb> kbsingh: yes, we should tell people about those
16:18:22 <kbsingh> but the push-atomc-images-into-ec2 task is plumbed into the gen-centos-cloud-images-vendor process
16:18:22 <jzb> them
16:19:06 <kbsingh> <end of update>
16:19:14 <jzb> kbsingh: awesome, thanks!
16:19:29 <jzb> walters: did you have anything to add this week?
16:20:20 <walters> just that whatever we can do to move forward with anaconda would be great.  I should be able to help with patch merging
16:20:27 <walters> one pain point is the lack of dist-git
16:20:42 <walters> because we have to continually merge the centos anaconda branding patches with the atomic patches
16:21:30 <kbsingh> how can we make that easier
16:21:55 <imcleod> walters: I should be doing that.  Apologies.  Do you expect the most recent downstream update to work if pulled in?
16:22:11 <imcleod> walters: If so, I'll grab it right now, reapply those few centos patches and kick off a CBS build.
16:23:18 <walters> kbsingh, dist-git would be a collaboration point, although we could just import the srpm into projectatomic git
16:23:33 <walters> i'm fine with the latter, just need to make a decision on where we keep the source
16:23:52 <kbsingh> where is projectatomic git ?
16:24:04 <walters> https://github.com/projectatomi
16:24:05 <walters> c
16:24:07 <kbsingh> we can host stuff on git.centos.org as well, with the free koji integration that would/could come from it
16:26:04 <jzb> kbsingh: can we just pull to git.centos.org from github?
16:26:07 <jzb> or push to?
16:26:38 <jzb> kbsingh: the reason I ask is we might get more contributions from folks on GitHub
16:26:41 <jzb> (might
16:26:59 <jzb> either way - let's make a decision today and go forward
16:27:15 <jzb> this seems to have come up several times and I think even a "bad" decision is better than no decision.
16:28:48 <kbsingh> so, i just checked..
16:29:06 <kbsingh> what we can do is setup a mirror inbound, and use that to build into koji from - but someone needs to take ownership for the mirror
16:29:26 <kbsingh> eg: imcleod might take it up to sync git.centos.org with content from github.com, and then request koji builds for the components
16:29:32 <jzb> imcleod: ^^ does that sound like you?
16:29:49 <imcleod> jzb: I'll give it a try.
16:29:53 <kbsingh> it can be a number of people, but it just needs to be a set of people who's details are setup at git
16:30:09 <kbsingh> ( as opposed to : running a mirror where anything on github automagically makes it to git.c.o )
16:30:41 <jzb> kbsingh: totally reasonable.
16:30:47 <imcleod> I don't believe I'm set up on g.c.o yet.
16:30:49 <imcleod> So I should do that.
16:31:20 <kbsingh> we can do some trial runs at Fosdem ( am hoping to do this with hhorak and the scl folks too )
16:31:23 <jzb> kbsingh: how does one get set up on gco?
16:31:34 <jzb> kbsingh: I'm seeing a login but not an obvious signup
16:31:49 <kbsingh> need to ask via bugs.centos.org includ sig name ( same as koji )
16:32:35 <kbsingh> unified central auth will make this redundant, a koji account gets you git automatically
16:33:45 <jzb> kbsingh: got it.
16:33:56 <jzb> kbsingh: one bug req per person or can we req several at once?
16:35:28 <jzb> imcleod: Imma give you the action to be Mr. Mirror, OK?
16:35:43 <imcleod> jzb: Sure.  Imma let you do that.
16:36:17 <jzb> awesome
16:36:49 <jzb> #action imcleod to request git.centos.org credentials, work on acting as "mirror" for github/atomic -> git.centos.org
16:37:05 <jzb> walters: do you want to set up a repo in github for this work?
16:37:10 <jzb> under the Atomic project?
16:38:43 <kbsingh> jzb: i think one per person is best, just easier to track
16:39:03 <jzb> kbsingh: ack, OK
16:39:17 <kbsingh> i think there might be quite a few repos, one per package ?
16:39:17 <jzb> might have lost walters to other stuff
16:39:46 <jzb> #action jzb work with walters and imcleod to set up github repo for collaboration
16:40:19 <jzb> #topic Activity Day at SCALE, Project Atomic at Devconf
16:40:39 <jzb> quick update - we're doing a Fedora Activity Day at SCALE around cloud + Atomic
16:41:14 <jzb> I know that's Fedora-specific-ish, but I suspect there's some overlap w/CentOS so I wanted to mention it here and welcome anybody (imcleod, Evolution) who might want to attend.
16:41:18 <jzb> it's on Sunday
16:41:32 <jzb> we're also doing a workshop on Saturday at DevConf.cz from lunch till end of day
16:41:36 <jzb> for Project Atomic
16:41:45 <jzb> I hope walters will be able to make that.
16:41:48 <Evolution> jzb: sure. can be there. I don't fly out until monday (scale)
16:41:55 <jzb> Evolution: excellent
16:41:55 <Evolution> devconf I can't do.
16:42:07 <jzb> Evolution: Yeah, I knew you were heading home from that
16:42:23 <jzb> that was my piece for this week
16:42:28 <jzb> #topic open floor
16:42:45 <jzb> any other topics this week? I think most folks are a bit slammed with other things, like getting ready for FOSDEM.
16:42:50 <jzb> nzwulfin: hey!
16:42:55 <kbsingh> I'm at devconf on Sat, will stop by
16:42:59 <jzb> nzwulfin: I see you made it
16:43:03 <jzb> nzwulfin: anything for this weeek
16:43:04 <jzb> ?
16:43:07 <jzb> kbsingh: awesome
16:44:48 <jzb> anybody?
16:44:49 <jzb> going once ...
16:45:23 <kbsingh> one thing..
16:45:34 <kbsingh> I've got 2 physical machines in ci.centos.org earmarked for atomic tests
16:45:35 <jzb> kbsingh: OK
16:45:40 <kbsingh> but i have no tests
16:45:55 <kbsingh> if anyone has tests floating around, do tell :)
16:46:12 <kbsingh> was hoping to work on this a bit early next week, but other firefighting going on
16:46:18 <jzb> kbsingh: perhaps we can work on that during the workshop in Brno
16:46:27 <kbsingh> I'm happy to demo etc at Dojo/Fosdem /devconf
16:46:35 <kbsingh> sounds good
16:46:51 <jzb> kbsingh: thanks!
16:48:47 <imcleod> Heh
16:48:51 <imcleod> sww
16:48:58 <jzb> OK
16:49:01 <jzb> calling it - thanks everybody
16:49:05 <jzb> #endmeeting