Product SiteDocumentation Site

1.121.  libsemanage

1.121.1.  RHBA-2009:1298: bug fix update

Updated libsemanage packages that fix multiple issues are now available.
libsemanage provides an API for the manipulation of SELinux binary policies. It is used by checkpolicy (the policy compiler) and similar tools, as well as by programs such as load_policy, which must perform specific transformations on binary policies (for example, customizing policy boolean settings)
These updated packages fix the following bugs:
  • dontaudit messages could not be disabled, which made it difficult for customers building their own security policies to identify which policies were being denied. This updated package includes the "sepol_set_disable_dontaudit" and "semanage_set_disable_dontaudit" functions, which allow dontaudit messages to be disabled. (BZ#493114)
  • corrected a specific versioned dependency issue relating to libsepol (BZ#512662)
All users of libsemanage are advised to upgrade to these updated packages, which resolve these issues.

Note: This documentation is provided {and copyrighted} by Red Hat®, Inc. and is released via the Open Publication License. The copyright holder has added the further requirement that Distribution of substantively modified versions of this document is prohibited without the explicit permission of the copyright holder. The CentOS project redistributes these original works (in their unmodified form) as a reference for CentOS-5 because CentOS-5 is built from publicly available, open source SRPMS. The documentation is unmodified to be compliant with upstream distribution policy. Neither CentOS-5 nor the CentOS Project are in any way affiliated with or sponsored by Red Hat®, Inc.