php 5.3.7

General support questions
Post Reply
maoie
Posts: 2
Joined: 2019/05/30 07:54:43

php 5.3.7

Post by maoie » 2019/05/30 08:00:15

I'm currently running centos 6.10 and i have currently php 5.3.3. I want to install roundcube 1.2.5 which requires php 5.3.7.

I tried upgrading to php5.4 using remi.repo but i keep getting this error:

--> Finished Dependency Resolution
Error: Package: php-cli-5.4.45-17.el7.remi.x86_64 (remi-php54)
Requires: libc.so.6(GLIBC_2.15)(64bit)
Error: mysql55w-libs conflicts with mysql-libs-5.1.73-8.el6_8.x86_64
Error: Package: php-pecl-memcache-3.0.8-4.el7.remi.5.4.x86_64 (remi-php54)
Requires: libc.so.6(GLIBC_2.15)(64bit)
Error: Package: php-xmlrpc-5.4.45-17.el7.remi.x86_64 (remi-php54)
Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: php-pgsql-5.4.45-17.el7.remi.x86_64 (remi-php54)
Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: php-xml-5.4.45-17.el7.remi.x86_64 (remi-php54)
Requires: libxml2.so.2(LIBXML2_2.9.0)(64bit)
Error: Package: php-tidy-5.4.45-17.el7.remi.x86_64 (remi-php54)
Requires: libtidy.so.5()(64bit)
Error: Package: php-xml-5.4.45-17.el7.remi.x86_64 (remi-php54)
Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: php-mbstring-5.4.45-17.el7.remi.x86_64 (remi-php54)
Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: php-pdo-5.4.45-17.el7.remi.x86_64 (remi-php54)
Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: php-soap-5.4.45-17.el7.remi.x86_64 (remi-php54)
Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: php-common-5.4.45-17.el7.remi.x86_64 (remi-php54)
Requires: libzip.so.2()(64bit)
Error: Package: php-gd-5.4.45-17.el7.remi.x86_64 (remi-php54)
Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: php-gd-5.4.45-17.el7.remi.x86_64 (remi-php54)
Requires: libpng15.so.15()(64bit)
Error: Package: php-gd-5.4.45-17.el7.remi.x86_64 (remi-php54)
Requires: libpng15.so.15(PNG15_0)(64bit)
Error: Package: php-odbc-5.4.45-17.el7.remi.x86_64 (remi-php54)
Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: php-imap-5.4.45-17.el7.remi.x86_64 (remi-php54)
Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: php-5.4.45-17.el7.remi.x86_64 (remi-php54)
Requires: libcrypto.so.10(OPENSSL_1.0.2)(64bit)
Error: Package: php-5.4.45-17.el7.remi.x86_64 (remi-php54)
Requires: libpcre.so.1()(64bit)
Error: Package: php-ldap-5.4.45-17.el7.remi.x86_64 (remi-php54)
Requires: libsasl2.so.3()(64bit)
Error: Package: php-mysql-5.4.45-17.el7.remi.x86_64 (remi-php54)
Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: php-cli-5.4.45-17.el7.remi.x86_64 (remi-php54)
Requires: libcrypto.so.10(OPENSSL_1.0.2)(64bit)
Error: Package: php-5.4.45-17.el7.remi.x86_64 (remi-php54)
Requires: httpd-mmn = 20120211x8664
Installed: httpd-2.2.15-69.el6.centos.x86_64 (@base)
httpd-mmn = 20051115
Error: Package: php-5.4.45-17.el7.remi.x86_64 (remi-php54)
Requires: libc.so.6(GLIBC_2.15)(64bit)
Error: Package: php-cli-5.4.45-17.el7.remi.x86_64 (remi-php54)
Requires: libxml2.so.2(LIBXML2_2.9.0)(64bit)
Error: Package: php-mcrypt-5.4.45-17.el7.remi.x86_64 (remi-php54)
Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: php-5.4.45-17.el7.remi.x86_64 (remi-php54)
Requires: libxml2.so.2(LIBXML2_2.9.0)(64bit)
Error: Package: php-common-5.4.45-17.el7.remi.x86_64 (remi-php54)
Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: php-common-5.4.45-17.el7.remi.x86_64 (remi-php54)
Requires: libgmp.so.10()(64bit)
Error: Package: php-bcmath-5.4.45-17.el7.remi.x86_64 (remi-php54)
Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: php-cli-5.4.45-17.el7.remi.x86_64 (remi-php54)
Requires: libpcre.so.1()(64bit)
Error: Package: php-pecl-apcu-4.0.11-2.el7.remi.5.4.x86_64 (remi-php54)
Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: php-process-5.4.45-17.el7.remi.x86_64 (remi-php54)
Requires: libc.so.6(GLIBC_2.14)(64bit)
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

Can anybody help me please? :)

Thanks!

User avatar
TrevorH
Forum Moderator
Posts: 26500
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: php 5.3.7

Post by TrevorH » 2019/05/30 08:52:08

You're trying to use the CentOS 7 version of Remi's repos on a CentOS 6 system. Use the CentOS 6 repo. To do that, first run yum clean all as root with the current el7 repo installed to get rid of its metadata. Then uninstall the remi-release package for el7, download the correct el6 copy, install it, try again.

You do know that php 5.4 went EOL some considerable time ago and that even the latest version will have unfixed security bugs? The distro php 5.3.3, even though it's older and "only 5.3" still gets security fixes from Redhat so is actually safer than the newer sounding version you're trying to use. Even php 5.6 is EOL.

Also, looking at your output, you have things from webtatic installed like mysql55w-libs. Do not try to mix and match remi's repos with webtatic - pick one of them and stick with it. Webtatic is not a repo we recommend using.

Also, roundcube is packaged and available in EPEL and works with the distro php
CentOS 5 died in March 2017 - migrate NOW!
CentOS 6 goes EOL sooner rather than later, get upgrading!
Full time Geek, part time moderator. Use the FAQ Luke

maoie
Posts: 2
Joined: 2019/05/30 07:54:43

Re: php 5.3.7

Post by maoie » 2019/06/03 05:41:12

ok. thanks you so much. i will do as you advised. :)

Post Reply

Return to “CentOS 6 - General Support”