Cannot start MySql when upgrading from version 5.5.55 to 5.6

General support questions
Post Reply
Scorpio
Posts: 1
Joined: 2019/06/13 01:57:50

Cannot start MySql when upgrading from version 5.5.55 to 5.6

Post by Scorpio » 2019/06/13 02:31:15

Earlier, I attempting to upgrade my MySQL using the SSH Client 'PuTTY'. I was looking to upgrade from MySQL 5.5.55 to MySQL 5.6.

Not having performed such an update before, I carefully following this article on the Plesk website:

https://support.plesk.com/hc/en-us/arti ... -on-Linux-

Where I headed to the 'Plesk on CentOS 6' Tab and managed to get as far as step 10.

As per the step, I then tried to start the MySQL. Unfortunately, this did not work; where I received the following message:

Code: Select all

MySQL Daemon failed to start
Starting mysqld: [FAILED]​
I have checked a variety of questions, on this forum, as well as other online resources. Unfortunately, nothing seems to be helping me. Maybe I am overlooking something.

Here is the latest MySQL Log:

[System] [MY-011012] [Server] Starting upgrade of data directory.
[ERROR] [MY-013090] [InnoDB] Unsupported redo log format (0). The redo log was created before MySQL 5.7.9
[ERROR] [MY-012930] [InnoDB] Plugin initialization aborted with error Generic error.
[ERROR] [MY-011013] [Server] Failed to initialize DD Storage Engine.
[ERROR] [MY-010020] [Server] Data Dictionary initialization failed.
[ERROR] [MY-010119] [Server] Aborting
[System] [MY-010910] [Server] /usr/sbin/mysqld: Shutdown complete (mysqld 8.0.16) MySQL Community Server - GPL.
[Warning] [MY-011070] [Server] 'Disabling symbolic links using --skip-symbolic-links (or equivalent) is the default. Consider not using this option as it' is deprecated and will be removed in a future release.
[System] [MY-010116] [Server] /usr/sbin/mysqld (mysqld 8.0.16) starting as process 4283
[System] [MY-011012] [Server] Starting upgrade of data directory.
[ERROR] [MY-013090] [InnoDB] Unsupported redo log format (0). The redo log was created before MySQL 5.7.9
[ERROR] [MY-012930] [InnoDB] Plugin initialization aborted with error Generic error.
[ERROR] [MY-011013] [Server] Failed to initialize DD Storage Engine.
[ERROR] [MY-010020] [Server] Data Dictionary initialization failed.
[ERROR] [MY-010119] [Server] Aborting
[System] [MY-010910] [Server] /usr/sbin/mysqld: Shutdown complete (mysqld 8.0.16) MySQL Community Server - GPL.
[Warning] [MY-011070] [Server] 'Disabling symbolic links using --skip-symbolic-links (or equivalent) is the default. Consider not using this option as it' is deprecated and will be removed in a future release.
[System] [MY-010116] [Server] /usr/sbin/mysqld (mysqld 8.0.16) starting as process 4608
[System] [MY-011012] [Server] Starting upgrade of data directory.
[ERROR] [MY-013090] [InnoDB] Unsupported redo log format (0). The redo log was created before MySQL 5.7.9
[ERROR] [MY-012930] [InnoDB] Plugin initialization aborted with error Generic error.
[ERROR] [MY-011013] [Server] Failed to initialize DD Storage Engine.
[ERROR] [MY-010020] [Server] Data Dictionary initialization failed.
[ERROR] [MY-010119] [Server] Aborting
[System] [MY-010910] [Server] /usr/sbin/mysqld: Shutdown complete (mysqld 8.0.16) MySQL Community Server - GPL.
[Warning] [MY-011070] [Server] 'Disabling symbolic links using --skip-symbolic-links (or equivalent) is the default. Consider not using this option as it' is deprecated and will be removed in a future release.
[System] [MY-010116] [Server] /usr/sbin/mysqld (mysqld 8.0.16) starting as process 4939
[System] [MY-011012] [Server] Starting upgrade of data directory.
[ERROR] [MY-013090] [InnoDB] Unsupported redo log format (0). The redo log was created before MySQL 5.7.9
[ERROR] [MY-012930] [InnoDB] Plugin initialization aborted with error Generic error.
[ERROR] [MY-011013] [Server] Failed to initialize DD Storage Engine.
[ERROR] [MY-010020] [Server] Data Dictionary initialization failed.
[ERROR] [MY-010119] [Server] Aborting
[System] [MY-010910] [Server] /usr/sbin/mysqld: Shutdown complete (mysqld 8.0.16) MySQL Community Server - GPL.

User avatar
TrevorH
Forum Moderator
Posts: 25810
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Cannot start MySql when upgrading from version 5.5.55 to 5.6

Post by TrevorH » 2019/06/13 06:20:04

Unfortunately, we only support what we ship and for CentOS 6, we ship mysql 5.1.73 not 5.5 nor 5.6 and definitely not the 8.0 that you appear to be running. You'll need to ask in a mysql forum for support.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke


Post Reply