rh-php70 cannot run in apache 2.2 in CentOS 6

Issues related to applications and software problems
Post Reply
yylib
Posts: 1
Joined: 2019/02/01 06:22:50

rh-php70 cannot run in apache 2.2 in CentOS 6

Post by yylib » 2019/02/01 06:50:31

I am using CentOS 6.10 with Apache 2.2. Recent, I have to upgrade PHP from 5.4 to 7.0. I downloaded rh-php70* packages. rh-php70 is enable. And php-v showed that the version is 7.0. However, an error message is returned when I restart httpd service.
undefined symbol: ap_unixd_config
Does rh-php70 compatible with apache 2.2? If yes, please provide some instructions to me.

User avatar
TrevorH
Forum Moderator
Posts: 26572
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: rh-php70 cannot run in apache 2.2 in CentOS 6

Post by TrevorH » 2019/02/01 14:37:40

What is the output from rpm -qa rh-php70\*
CentOS 5 died in March 2017 - migrate NOW!
CentOS 6 goes EOL sooner rather than later, get upgrading!
Full time Geek, part time moderator. Use the FAQ Luke

User avatar
remirepo
Posts: 337
Joined: 2014/09/21 09:07:12
Location: France
Contact:

Re: rh-php70 cannot run in apache 2.2 in CentOS 6

Post by remirepo » 2019/02/01 15:23:17

> Does rh-php70 compatible with apache 2.2? If yes, please provide some instructions to me.

The rh-php70-php package only provides the mod_php module for httpd 2.4 from httpd24 SCL

(and you should not be able to install it without the proper dependency)
Remi's Repository - Forum - Blog

User avatar
TrevorH
Forum Moderator
Posts: 26572
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: rh-php70 cannot run in apache 2.2 in CentOS 6

Post by TrevorH » 2019/02/01 15:53:24

The rh-php70-php package only provides the mod_php module for httpd 2.4 from httpd24 SCL
I am using rh-php70 packages on CentOS 6 with httpd 2.2.15 and it works just fine. Are you thinking of CentOS 7?

Looking further, it seems that you have to run rh-php70-php-fpm.
CentOS 5 died in March 2017 - migrate NOW!
CentOS 6 goes EOL sooner rather than later, get upgrading!
Full time Geek, part time moderator. Use the FAQ Luke

User avatar
remirepo
Posts: 337
Joined: 2014/09/21 09:07:12
Location: France
Contact:

Re: rh-php70 cannot run in apache 2.2 in CentOS 6

Post by remirepo » 2019/02/02 07:46:47

using FPM is very simple with httpd 2.4 (SetHandler to fcgi proxy)

With httpd 2.2 in C6, not so easy (ProxyPass... using mod_proxy-fcgi from EPEL)

IMHO, far simpler to use httpd24 SCL
Or switch to C7.
Remi's Repository - Forum - Blog

Post Reply

Return to “CentOS 6 - Software Support”