NFS Issue

Issues related to applications and software problems
Post Reply
p78.w
Posts: 15
Joined: 2019/02/01 09:21:47

NFS Issue

Post by p78.w » 2019/02/19 14:23:56

Hi
We have a power failure and had some issues which are being worked thru, my centos backup server is now not able to connect to a NAS device.

mount.nfs: access denied by server while mounting 10.10.4.x:/FS/M1
mount.nfs: access denied by server while mounting 10.10.4.x:/FS/M2
mount.nfs: access denied by server while mounting 10.10.4.x:/FS/M3

The nas had to be re-joined to the windows AD domain, so I am guessing that is the issue, but I have no idea where to start as I have read as much as possible to get this up and running and am lost!

NFS does not require a username / password to connect to the shares, I have checked /etc/export (blank) and have updated it

Any pointers much appreciated.

stevemowbray
Posts: 480
Joined: 2012/06/26 14:20:47

Re: NFS Issue

Post by stevemowbray » 2019/02/19 14:48:53

The file which defines shares on the server is /etc/exports, not /etc/export.

tunk
Posts: 622
Joined: 2017/02/22 15:08:17

Re: NFS Issue

Post by tunk » 2019/02/19 14:49:15

Just guessing, if you had to rejoin, then some other settings like the firewall may have been reset as well.
I assume that /etc/export is a typo (it should be /etc/exports)? And that you updated it on the NAS?

p78.w
Posts: 15
Joined: 2019/02/01 09:21:47

Re: NFS Issue

Post by p78.w » 2019/02/19 16:11:02

fixed it, as NAS had lost all settings for backup server.

I have another open chat, under networking, two eth0 and eth 4 nics online!!

If you can assist, much appricated!

Post Reply

Return to “CentOS 6 - Software Support”