bastille work around

Support for security such as Firewalls and securing linux
Post Reply
egarnel
Posts: 9
Joined: 2005/01/18 16:12:22
Contact:

bastille work around

Post by egarnel » 2005/05/03 14:42:14

I tried installing running bastille on a centos system, it would not work from rpm so I installed from source instead. It worked after the source install, but complained about the redhat version. Scanning the source, it appears to read the /etc/redhat-release file at various times.

A quick work-around was to backup the redhat-release file (mv to a diff name) and then edit it with the following:

Red Hat Enterprise Linux AS release 4

I then re-ran bastille and it complained a lot less! afterwords, I moved the original redhat-release file back "CentOS release 4.0 (Final)"

I have emailed the fine folks at bastille-linux to please add CentOS into the accepted releases

gking
Posts: 12
Joined: 2005/06/23 15:22:03

Re: bastille work around

Post by gking » 2005/06/23 15:35:40

I set this up last night. Here is the link with the diff to apply to the API file:

http://sourceforge.net/mailarchive/forum.php?thread_id=7281798&forum_id=7003

egarnel
Posts: 9
Joined: 2005/01/18 16:12:22
Contact:

Re: bastille work around

Post by egarnel » 2005/07/08 12:09:18

Just heard back from Jay. Version 3.0.5-1.1 now supports CentOS. I will give it a try on a test server and post any issues that I run into

Post Reply

Return to “CentOS 4 - Security Support”