CUPS - Idle - Filter failed

General support questions
Post Reply
Kar1naK
Posts: 2
Joined: 2019/06/10 17:10:04

CUPS - Idle - Filter failed

Post by Kar1naK » 2019/06/10 17:26:08

Hi everyone,

I have a network printer set up via SAMBA on my laptop and after doing some updates it no longer prints.
When trying to print anything, the printer state goes to Idle - Filter failed.

Error log:

https://pastebin.com/mLsQDAFR

Looking online, seems that this might be related to ghostscript or cups-filters, some recommended downgrading them but I'm not sure how, as most of these problems were reported by people using Fedora, Redhat, Debian and I found nothing relating to this problem on CentOS.

I'm running the latest ML Kernel, 5.1.8

Any help would be highly appreciated.

Thank you,
Alex

MartinR
Posts: 426
Joined: 2015/05/11 07:53:27
Location: UK

Re: CUPS - Idle - Filter failed

Post by MartinR » 2019/06/10 19:48:03

I had a similar unreliability in CUPS some time back, the filter failed and I couldn't restart the queue. I've just checked my notes and all I've recorded is "Problem: Printer errors and CUPS takes it offline", "Solution: cupsenable(8)". Not a lot of help I'm afraid.

I did notice from your error log that the problem seems to be with the first job.

Code: Select all

D [10/Jun/2019:16:24:31 +0100] [Job 1] GPL Ghostscript 9.07: Unrecoverable error, exit code 1
D [10/Jun/2019:16:24:31 +0100] [Job 1] Process is dying with "Unable to determine number of pages, page count: -1
D [10/Jun/2019:16:24:31 +0100] [Job 1] ", exit stat 3
D [10/Jun/2019:16:24:31 +0100] [Job 1] Cleaning up...
D [10/Jun/2019:16:24:31 +0100] [Job 1] PID 11791 (/usr/lib/cups/filter/foomatic-rip) stopped with status 3.
D [10/Jun/2019:16:24:31 +0100] [Job 1] Hint: Try setting the LogLevel to "debug" to find out more.
D [10/Jun/2019:16:24:31 +0100] [Job 1] PID 11792 (/usr/lib/cups/backend/smb) exited with no errors.
D [10/Jun/2019:16:24:31 +0100] [Job 1] End of messages
D [10/Jun/2019:16:24:31 +0100] [Job 1] printer-state=3(idle)
D [10/Jun/2019:16:24:31 +0100] [Job 1] printer-state-message="Filter failed"
D [10/Jun/2019:16:24:31 +0100] [Job 1] printer-state-reasons=none
E [10/Jun/2019:16:29:33 +0100] [Job 1] Stopping unresponsive job.
See the first three lines.

lightman47
Posts: 909
Joined: 2014/05/21 20:16:00
Location: Central New York, USA

Re: CUPS - Idle - Filter failed

Post by lightman47 » 2019/06/10 20:48:21

You're not going to like this (I didn't).

After a recent (quick) power outage, our $$$ Dell printer started producing the 'filter failed' messages - to all the network machines. I was unable to get rid of it (reboots of EVERYTHING, etc. didn't help). The printer still PINGed perfectly, but prints backed up in the (stopped) queue.

Replacing the printer solved the problem. I hope you have a better outcome.

Kar1naK
Posts: 2
Joined: 2019/06/10 17:10:04

Re: CUPS - Idle - Filter failed

Post by Kar1naK » 2019/06/11 13:45:35

@MartinR, lightman47

Thank you for your inputs, but I'm working in a large institute and all of our printers (100+) are a mix Canon IR-ADV C5250 and C350i MFDs.
On CentOS 7 the UFR II drivers you get from Canon work, but half of the paper comes out with inverted colours and there's no fix for this.

The only driver I found to be working on CentOS 7 & 6 and doesn't have the inverted color issue is this one:

https://www.openprinting.org/printer/Ca ... ner_C5185i

Coming back at the issue at hand, upon further research I came across this:

https://bugzilla.redhat.com/show_bug.cgi?id=1707559

It's mentioned that the issue was fixed in foomatic-4.0.9-9.el7 but that doesn't seems the case at least for me, as I've tried upgrading foomatic but it did not help.

The main cause of the issue for me was the latest version of ghostscript (ghostscript-9.07-31.el7_6.11.x86_64). In order to fix it, I had to downgrade to ghostscript-9.07-31.el7_6.10.x86_64 and ghostscript-cups-9.07-31.el7_6.10.x86_64

As ghostscript depend has other dependencies, I had to manually find and download the 9.07-31.el7_6.10.x86_64.rpm packages, remove the current versions of ghost script and cups, then install the rpms with the --nodeps parameter:

sudo rpm -Uhv --nodeps '/location/ofthefile/ghostscript-cups-9.07-31.el7_6.10.x86_64.rpm

sudo rpm -Uhv --nodeps '/location/ofthefile/ghostscript-9.07-31.el7_6.10.x86_64.rpm

After this two finish installing, you just install cups and start the service:

sudo yum install cups
sudo systemctl start cups

Hopefully this will help other people if they come across the same issue.

Kind regards,
Alex

lightman47
Posts: 909
Joined: 2014/05/21 20:16:00
Location: Central New York, USA

Re: CUPS - Idle - Filter failed

Post by lightman47 » 2019/06/14 16:10:46

Now I don't like it!! (from my above response):

Just fired up my old Dell 3000cn, plugged in my laptop and booted Windows 10 - printer works just fine.

Oh well - it was old. Guess I'll see if I can get anything for it.

{head banging on wall here}

Post Reply