Issue with updating mesa* packages

General support questions
Post Reply
mahmood
Posts: 113
Joined: 2017/06/04 12:21:09

Issue with updating mesa* packages

Post by mahmood » 2019/06/15 16:31:27

When I want to install wine from epel, I get a lot of dependency errors regarding mesa package, e.g. libEGL, which have to be updated

Code: Select all

Error: Package: mesa-libEGL-18.0.5-4.el7_6.i686 (updates)
           Requires: libwayland-client.so.0
Error: Package: mesa-libEGL-18.0.5-4.el7_6.i686 (updates)
           Requires: libglvnd-egl(x86-32)
As you can see currently, libEGL is installed from another repository

Code: Select all

Installed Packages
mesa-libEGL.i686                              17.0.1-6.20170307.el7                      @Rocks-7.0
mesa-libEGL.x86_64                            17.0.1-6.20170307.el7                      @anaconda/7.0
mesa-libEGL-devel.x86_64                      17.0.1-6.20170307.el7                      @anaconda/7.0
Available Packages
mesa-libEGL.i686                              18.0.5-4.el7_6                             updates
mesa-libEGL.x86_64                            18.0.5-4.el7_6                             updates
mesa-libEGL-devel.i686                        18.0.5-4.el7_6                             updates
mesa-libEGL-devel.x86_64                      18.0.5-4.el7_6                             updates
I tried disabling in proper repositories, but there was no success.

How can I safely update the packages?

chemal
Posts: 515
Joined: 2013/12/08 19:44:49

Re: Issue with updating mesa* packages

Post by chemal » 2019/06/15 16:55:11

Rocks 7.0 is based on CentOS 7.4. It won't work with the CentOS updates repository for 7.6.

Post Reply