Problems installing Nvidia drivers for Cent OS 7

Issues related to applications and software problems
hachi
Posts: 13
Joined: 2019/04/14 21:52:16

Re: Problems installing Nvidia drivers for Cent OS 7

Post by hachi » 2019/05/02 06:41:30

if optirun works as root but not for your user, your user is probably not memeber of the 'bumblebee' group

see documentation from elrepo,

Code: Select all

2)Add your user account to group bumblebee.

miney
Posts: 10
Joined: 2019/04/13 11:55:06

Re: Problems installing Nvidia drivers for Cent OS 7

Post by miney » 2019/05/02 17:37:52

I have no different behaviour between root and my normal user (who is part of group bumblebee), so no, that is not the problem.

fishingman78
Posts: 6
Joined: 2011/04/09 03:21:28

Re: Problems installing Nvidia drivers for Cent OS 7

Post by fishingman78 » 2019/05/30 04:26:23

First off, the error you saw about the keyboard results from optirun not finding your GPU. The default xorg.conf.nvidia from elrepo has the line,

BusID "PCI:XX:XX:X"

commented out. As long as your xorg.conf.nvidia file explicitly points to the device, you should not see that error anymore. This has been posted on other websites. Unfortunately, I do not have any links on hand.

Second, I think your problem is with primus and not optirun, since I am having the same problem. According to your bumblebee.conf, the bridge is set to primus. You may want to try,

$ optirun -b virtualgl glxspheres64

If I can finally find a solution for primus, I will try post it here.

miney
Posts: 10
Joined: 2019/04/13 11:55:06

Re: Problems installing Nvidia drivers for Cent OS 7

Post by miney » 2019/06/06 11:29:22

As stated below: When I run lspci | grep -i nvidia, this is what I get:

Code: Select all

02:00.0 3D controller: NVIDIA Corporation GM108M [GeForce 940MX] (rev a2)
Therefore the corresponding line in my xorg.conf.nvidia is:

Code: Select all

BusID "PCI:2:0:0"
I also tried variations of that like "PCI:02:00:00" or "PCI:02:00:0", which makes no difference, the error still occurs with both, virtualgl or primus.

Code: Select all

[ERROR]Cannot access secondary GPU - error: [XORG] (EE) kbd: <default keyboard>: failed to set us as foreground pgrp (Inappropriate ioctl for device)

fishingman78
Posts: 6
Joined: 2011/04/09 03:21:28

Re: Problems installing Nvidia drivers for Cent OS 7

Post by fishingman78 » 2019/06/10 04:21:13

Are using the drivers suggested by nvidia-detect or are you still using the drivers downloaded from NVIDIA website? Are you using the kmod-nvidia-XXXxx that corresponds to the drivers from elrepo?

miney
Posts: 10
Joined: 2019/04/13 11:55:06

Re: Problems installing Nvidia drivers for Cent OS 7

Post by miney » 2019/06/10 20:29:28

I think so...

nvidia-detect gives me:

Code: Select all

kmod-nvidia
An Intel display controller was also detected
I also used nvidia-detect to install the drivers.

When I run sudo yum list installed | grep -i nvidia, this is what I get:

Code: Select all

Loaded plugins: fastestmirror, langpacks, nvidia
kmod-nvidia.x86_64                      418.74-1.el7_6.elrepo          @elrepo  
nvidia-detect.x86_64                    418.74-1.el7.elrepo            @elrepo  
nvidia-x11-drv.x86_64                   418.74-1.el7_6.elrepo          @elrepo  
nvidia-x11-drv-libs.x86_64              418.74-1.el7_6.elrepo          @elrepo  
yum-plugin-nvidia.noarch                1.0.2-1.el7.elrepo             @elrepo  

Post Reply

Return to “CentOS 7 - Software Support”