Cant start smb.service

Issues related to applications and software problems
Post Reply
Posts: 10
Joined: 2019/04/11 08:46:27

Cant start smb.service

Post by rexorbrave » 2019/06/08 19:47:35

Dear all,

When I tried to install plexmediaserver on Centos 7 yesterday, it used the wrong folder, so i uninstalled it and reinstalled it. I noticed that I could no longer start the service, it gave me an error. Since then I have also not been able to restart/start my samba server. I was wondering if anyone would be able to help me out. By now I have, removed the plexserver, reinstalled samba multiple times, but all without results.

The samba log is empty, the error tells the following:

Code: Select all

● smb.service - Samba SMB Daemon
   Loaded: loaded (/usr/lib/systemd/system/smb.service; disabled; vendor preset: disabled)
   Active: failed (Result: exit-code) since Sat 2019-06-08 21:35:25 CEST; 7min ago
     Docs: man:smbd(8)
  Process: 4637 ExecStart=/usr/sbin/smbd --foreground --no-process-group $SMBDOPTIONS (code=exited, status=1/FAILURE)
 Main PID: 4637 (code=exited, status=1/FAILURE)

Jun 08 21:35:25 localhost.localdomain systemd[1]: Starting Samba SMB Daemon...
Jun 08 21:35:25 localhost.localdomain systemd[1]: smb.service: main process exited, code=exited, status=1/FAILURE
Jun 08 21:35:25 localhost.localdomain systemd[1]: Failed to start Samba SMB Daemon.
Jun 08 21:35:25 localhost.localdomain systemd[1]: Unit smb.service entered failed state.
Jun 08 21:35:25 localhost.localdomain systemd[1]: smb.service failed.
And testparm tells me:

Code: Select all

[root@localhost private]# testparm
Load smb config files from /etc/samba/smb.conf
rlimit_max: increasing rlimit_max (1024) to minimum Windows limit (16384)
Processing section "[Minecraft Server]"
Processing section "[Storage]"
Loaded services file OK.
WARNING: You have some share names that are longer than 12 characters.
These may not be accessible to some older clients.
(Eg. Windows9x, WindowsMe, and smbclient prior to Samba 3.0.)

Press enter to see a dump of your service definitions

# Global parameters
        dns proxy = No
        map to guest = Bad User
        netbios name = SERVER1
        security = USER
        server string = Samba Server %v
        workgroup = ORIZON
        idmap config * : backend = tdb

[Minecraft Server]
        path = /home/minecraft_server
        read only = No
        valid users = @Myusername

        path = /home/storage
        read only = No
        valid users = @Myusername
I think it might have broken when I tried to map a samba share to /var/lib/plexmediaserver
But that was couple of uninstalls ago, so at this point I really don't have a clue.

Thanks in advance!

Post Reply

Return to “CentOS 7 - Software Support”