10:03:55 <gfidente> #startmeeting CentOS Storage SIG meeting (2020-03-03)
10:03:55 <centbot> Meeting started Tue Mar  3 10:03:55 2020 UTC.  The chair is gfidente. Information about MeetBot at http://wiki.debian.org/MeetBot.
10:03:55 <centbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
10:04:28 <fmount> o/
10:04:30 <gfidente> #link meeting agenda https://hackmd.io/Epc35JIESaeotoGzwu5R5w
10:05:45 <gfidente> I guess we can try to go quickly through the topics we have in the agenda
10:06:09 <fmount> yeah
10:06:16 <gfidente> and see if there is anything worth sharing in the list to try rise awareness and get feedback
10:06:33 <gfidente> #topic (mnasiadka) need to align c7 ceph/nautilus with the c8 version
10:06:55 <gfidente> mnasiadka go ahead
10:08:11 <mnasiadka> Yes, I'm just a consumer (core in OpenStack/Kolla family in projects), but what struck me was 1) announcement on ceph-discuss ML that the only available build for CentOS 8 will be Octopus, nothing earlier due to some dependencies issues, etc 2) CentOS Storage SIG releasing test packages for Nautilus on CentOS 8
10:08:46 <gfidente> wait that was the other topic you also had
10:09:00 <gfidente> :D
10:09:06 <mnasiadka> oh, I think it's too early and I got confused - didn't have coffee yet :)
10:09:19 <gfidente> mnasiadka++ it's all good and thanks for joining
10:09:26 <gfidente> so c7 nautilus builds
10:09:37 <mnasiadka> ah, versions way back in c7 nautilus
10:09:45 <mnasiadka> and newer minor version in c8 nautilus
10:09:53 <mnasiadka> (only in c8)
10:09:55 <gfidente> I did manage to build 14.2.7 for c7 as well
10:09:58 <mnasiadka> gfidente: thanks for waking me up :)
10:09:59 <gfidente> #link https://cbs.centos.org/koji/buildinfo?buildID=28922
10:10:09 <gfidente> it's tagged in -testing
10:10:26 <gfidente> I did not tag it -release yet because some of the sub-packages need dependencies which we don't have for c7
10:10:45 <gfidente> but the daemons (mons/mgrs/osds/rgw/...) can be installed without issues
10:10:57 <mnasiadka> ok, we have users waving flags that ceph-nautilus packages on centos 7 are really old, and asking if we can move to download.ceph.com packages
10:11:02 <gfidente> the parts which need additional deps are the rook orchestrator
10:11:18 <mnasiadka> ok, we are interested mainly in client libraries (python-rbd, and so on)
10:11:24 <gfidente> I guess I can tag -release what we have now
10:11:25 <mnasiadka> for Nova/Cinder
10:11:46 <gfidente> but it'd be nice to get some help with the other missing deps
10:12:02 <mnasiadka> Daemons - Kolla's Ceph deployment mechanism has been deprecated and removed in Ussuri - so it's not our priority anymore
10:12:08 <gfidente> #action gfidente tag https://cbs.centos.org/koji/buildinfo?buildID=28922 into -release
10:12:19 <mnasiadka> If there's something like a low-hanging-fruit I could help with - I'm happy to help
10:12:45 <gfidente> mnasiadka no I am the guy usually dealing with low-hanging-fruit already :D
10:13:01 <gfidente> mnasiadka to be fair, rdo guys used to build the majority of the ceph deps in cbs for openstack anyway
10:13:06 <mnasiadka> gfidente: I can take something over, so you can be promoted to the complicated stuff :)
10:13:12 <gfidente> so a good part of the deps can just be cross-tagged from cloud into storage
10:14:06 <gfidente> mnasiadka yeah I guess we need to figure how to give you permissions into cbs to mess with it
10:14:36 <gfidente> mnasiadka thanks for volunteering indeed
10:14:46 <gfidente> fmount not sure if you have cycles to look into that or prefer me to?
10:14:47 <fmount> gfidente: we can help w/ deps, and in the meantime we can tag -release the existing working packages
10:15:28 <fmount> gfidente: yes I can try of course, I'll ask you for some info
10:15:36 <gfidente> fmount I think if mnasiadka could get permissions it'd help openstack as whole not just kolla
10:16:00 <fmount> right
10:16:06 <fmount> thanks mnasiadka
10:16:18 <gfidente> #action fmount look into how to get permissions for mnasiadka into cbs
10:16:36 <gfidente> meantime we'll tag 14.2.7 el7 -release
10:16:47 <gfidente> so next topic?
10:17:03 <gfidente> (is that the correct syntax for #action command?)
10:17:28 <gfidente> #topic (mnasiadka) will there be ceph/nautilus in ussuri (c8) or ceph/octopus
10:17:54 <gfidente> mnasiadka you up again, so yeah we have a problem where download.ceph.com and cbs make each their own builds
10:18:00 <gfidente> download.ceph.com used to depend on EPEL
10:18:05 <gfidente> which cbs doesn't want to
10:18:18 <mnasiadka> Yes, Kolla has a history of being surprised by RDO requiring latest and greatest Ceph version when OpenStack release is being cut
10:18:35 <gfidente> presently there are no plans to build nautilus for c7 via download.ceph.com
10:18:46 <gfidente> while there will be nautilus (as it used to) for c7 via cbs
10:18:49 <gfidente> and also for c8 via cbs
10:19:03 <gfidente> octopus will be for c8 only, in both cbs and download.ceph.com
10:19:41 <gfidente> not sure if that answer your question or if there is an open thread on the list somewhere where we should share this?
10:20:38 <mnasiadka> Not yet, but I could start a thread on the openstack mailing list, and you can respond what's the plan :)
10:21:19 <gfidente> mnasiadka well, let's keep it quick, you can take as summary from the meeting the idea and share on the list
10:22:14 <gfidente> #info cbs will have ceph/nautilus for both centos7 and centos8 while ceph/octopus will be centos8 only
10:22:23 <mnasiadka> gfidente: makes sense
10:22:48 <fmount> I agree with the idea of a thread in the ML, we can share the plan there
10:22:58 <gfidente> and I can't talk about download.ceph.com really, kdreyer would probably be best person for that, but he can't join at this hour
10:23:17 <gfidente> fmount mnasiadka can you add Ken to the thread for awareness / feedback ?
10:23:27 <mnasiadka> sure, will do
10:23:34 <fmount> gfidente: should we consider moving this meeting?
10:23:38 <fmount> for the future
10:23:57 <gfidente> #action mnasiadka share ceph nautilus and octopus availability in cbs with the -devel list
10:24:02 <fmount> to allow people (like kdreyer) to join?
10:24:18 <gfidente> fmount I am not sure what to do, or how to do it honestly
10:24:26 <gfidente> shall we make a poll on the list?
10:25:09 <fmount> not sure, but it could be a good starting point
10:26:03 <gfidente> we could gather interest like that
10:26:09 <gfidente> maybe
10:26:18 <gfidente> more people will be able to join then
10:26:22 <gfidente> do you want to start the thread?
10:26:30 <fmount> sure
10:26:54 <fmount> I'll do
10:27:06 <gfidente> #action fmount poll -devel list about best meeting time to get more people involved
10:27:07 <fmount> and share the agenda we creted
10:27:10 <gfidente> yeah
10:27:21 <gfidente> logs should be generated automatically
10:27:34 <gfidente> ok
10:27:40 <gfidente> no other topics in the agenda
10:28:05 <fmount> no no other topics
10:28:11 <gfidente> not sure if people had other stuff?
10:28:53 <fmount> mnasiadka: are you ok or have you other topics for today?
10:29:14 <mnasiadka> I think I'm all right :)
10:29:26 <gfidente> #endmeeting