16:01:35 <amoloney> #startmeeting CentOS Stream Feature Request SIG weekly meeting
16:01:35 <centbot> Meeting started Tue Jun  1 16:01:35 2021 UTC.  The chair is amoloney. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:35 <centbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
16:02:05 * rbowen waves
16:02:25 <bstinson> hey all
16:02:31 <alukoshko> Hi all
16:02:39 <dcavalca> ohai
16:03:04 <bexelbie> o/
16:03:06 <bexelbie> .hello bex
16:03:42 <themayor> Hello friends
16:03:57 <amoloney> #agenda chair(s) assignment, meeting cadences, membership, feature process pipeline review, goals
16:04:10 <amoloney> welcome everyone!
16:04:44 <amoloney> This is this SIGs first call and we have a few items to establish first
16:05:02 <amoloney> so, who wants to be chair & co-chair? :)
16:05:25 <bstinson> i can help with that
16:05:46 <amoloney> Thanks Brian, I vote you too :)
16:05:56 <siddharthvipul> I nominate bstinson
16:06:09 <amoloney> also Im happy to help out as well
16:07:56 <amoloney> chair duties for this SIG are same as others? Scheduling, agenda creation, action item assignment and follow ups?
16:08:53 <amoloney> the wider group should have shared ownership on reviewing bugzillas and creating features in jira to be worked on
16:09:52 <amoloney> these are my 2c's, please disagree or add to them :)
16:10:16 <rbowen> +1
16:13:19 <amoloney> Im going to give 3 more mins for feedback on the SIG chair responsibilities and then take it as set as those items
16:13:24 <amoloney> in the interest of time
16:13:26 <bstinson> +1 from me
16:13:33 <bexelbie> +1
16:13:52 <rbowen> Yes, I think that's an accurate summary of chair responsibilities. Also, quarterly reporting. :)
16:14:16 <amoloney> thanks Rich, good spot!
16:14:34 <themayor> +1 sounds good
16:14:35 <amoloney> Next thing to get nailed down is to get agreement on the meeting cadences and times
16:14:51 <amoloney> my cryptonite (time) :)
16:15:50 <amoloney> ok, its 1715 so SIG chair responsibilities are confirm
16:15:59 <amoloney> #agreed bstinson is chair
16:16:34 <amoloney> #agreed chair will schedule meeting,put together agenda, assign actions and follow ups and report quarterly
16:17:38 <amoloney> #agreed there is shared responsibility among the SIG members to review bugzillas for feature requests and bring them to the SIG group meetings for discussion and decision to create a feature request in jira for Stream
16:18:08 <amoloney> #topic Meeting Times & cadences
16:18:22 <amoloney> are we all good with *this time* on Tuesdays every week?
16:18:38 <rbowen> I am fine with this date/time. Works for me.
16:18:45 <bstinson> i'm happy with it
16:18:50 <amoloney> its 5pm here in Ireland so whatever it is in your respective countries!
16:19:23 <amoloney> giving this until 17.25 for input
16:19:31 <amoloney> then running with the consensus
16:22:29 <bexelbie> +1
16:23:55 <jwboyer> apologies for being late
16:24:16 <jwboyer> this time mostly works for me, but i may have conflicts at the start from time to time
16:25:15 <amoloney> I think we can run with this time so
16:26:07 <amoloney> is this 1700 UTC+1?
16:26:20 <amoloney> timezone conversion is really not my thing
16:26:48 <rbowen> 1600 UTC
16:26:50 <rbowen> So, yes.
16:26:52 <amoloney> thanks :)
16:26:57 <rbowen> `date -d` is my friend. :)
16:27:01 <bstinson> yay offset math
16:27:14 <rbowen> `date -d "1600 UTC"`
16:27:28 <themayor> It’s currently 15:26 in UTC+1
16:27:37 <amoloney> #agreed SIG will meet on Tuesdays @ 1600 UTC+1 on #centos-meeting
16:27:44 <themayor> Sorry 17:26
16:27:45 <rbowen> And .... I'm confused again. Oh well.
16:27:47 <amoloney> can we not just say 5pm in Ireland
16:27:56 <amoloney> joking :)
16:28:01 <amoloney> ok next topic
16:28:12 <rbowen> FWIW, the calendar tool uses UTC, and so it's always weirdly offset for *someone* for a few weeks a year.
16:28:27 <amoloney> #topic Expanding Membership
16:29:38 <amoloney> How should we expand membership of this SIG? Does anyone have any ideas?
16:30:04 <amoloney> giving this until 17.45 as this is an important piece to discuss
16:30:05 <rbowen> By the "raise your hands if you want to be part of it" method, would be my vote.
16:30:17 <jwboyer> do we have a need to expand?
16:30:19 <bstinson> i think we need to maybe have a few sessions about expectations though
16:30:29 <rbowen> We have (at least?) three people who have showed up for this meeting who are not on the initial list.
16:30:42 <amoloney> so the first step is to attend the meetings
16:31:07 <amoloney> perhaps when we dig into the bz's there may be some action items members can take?
16:31:17 <bstinson> yes! attending meetings and participating in discussion is what we want
16:31:38 <rbowen> There's no "cost" associated with SIG members who aren't particularly active. But,yes, ideally, being active is the expectation.
16:31:41 <amoloney> or would there be tasks outside of 'the tech' that people can get involved in?
16:31:53 <bstinson> i will note that there will be a fair amount of shepherding things around with different teams in Red Hat, some of this is related to how we plan things internally
16:32:02 <bstinson> i do not expect non-Red Hatters to carry any of that burden
16:32:35 <rbowen> Mostly I'd expect SIG members to speak up loudly about the things they care about.
16:33:18 <bstinson> we should expect non-SIG members to do that too!
16:33:24 <amoloney> what about coordinating with a 'red-hat shepard' to report out to the CentOS community on progress of community requests?
16:33:55 <bstinson> that may be an additional responsibility of the chair(s)
16:34:55 <amoloney> true, but having someone with a vested interest to lightly pester the chair(s) for progress/updates to make sure community requests are prioritized could be very beneficial
16:35:07 <amoloney> and I stress, lightly :)
16:35:40 <themayor> fwiw, we have 3 folks from our team that would love to be involved and help in any way we can
16:35:52 <jwboyer> that sounds more like expanding participation, which is different to me than expanding membership
16:36:30 <rbowen> "SIG membership" is a largely undefined term. It means that you're in the AAA group, but beyond that, it's up to each SIG to define what membership signifies.
16:38:02 <rbowen> jwboyer: So, what does "membership" mean to you, then?
16:38:45 <amoloney> lets try establish that then, or at least get a start on what we think membership would mean
16:39:05 <jwboyer> the group of people responsible for reviewing, validating, and pushing feature requests through to completion
16:39:29 <jwboyer> aka "the people stuff gets assigned to for accountability"
16:39:52 <jwboyer> anyone can discuss or propose a feature.  a member would take responsibility for getting an answer or action completed
16:40:49 <amoloney> I would agree with that
16:42:03 <rbowen> I just don't want to artificially keep anyone out because they have less time, or don't have a red hat. There's no cost to having an inactive member.
16:42:58 <jwboyer> if the default is "show up and talk about stuff", i can't imagine how we could keep anyone out
16:44:44 <bstinson> i think it's ok to keep our "membership" small so that we keep a focus on accountability
16:44:56 <bstinson> but there's no "you must become a member" ceremony to get your feature discussed
16:46:34 <rbowen> I suppose the opposite question is, what privilege/feature do you get when you're a 'member' that you don't otherwise. Which is also largely undefined for a SIG that doesn't produce packages.
16:48:00 <amoloney> do you think we need to spend a little more time on this one?
16:48:09 <bstinson> you get to pay attention to features as a whole and are accountable to provide an answer to the group and the community about those that you take on
16:48:30 <bstinson> more time on this would be good, /me makes a note for the next agenda
16:49:16 <amoloney> #agreed membership criteria needs more review - will be added to the next agenda
16:49:53 <themayor> #agreed
16:51:32 <amoloney> #topic verify the feature request process is in place
16:51:59 <amoloney> so is there anything were missing in the process thats blocking people to get something looked at?
16:53:46 <bstinson> https://wiki.centos.org/SpecialInterestGroup/StreamFeatureRequest
16:53:49 <bstinson> this is a good start
16:54:11 <bstinson> by next week, i'll have a couple of bugzilla queries that we can use during our triage
16:54:43 <rbowen> I was going to say - having a few guinea pigs to test the process with would be a great start.
16:55:04 <amoloney> perfect, I wanted to make sure we hadnt a step missed in the docs
16:56:19 <themayor> So we have a feature (package) which we’d like to nominate for inclusion
16:56:47 <amoloney> I think we can call an action on that?
16:57:24 <bstinson> themayor: did you want to give us a preview of your nomination?
16:58:38 <themayor> Yes so we’d like to see open-vm-tools for aarch64 included
16:59:01 <themayor> Currently it’s not available and the relevant bz doesn’t offer much info
16:59:04 <themayor> https://bugzilla.redhat.com/show_bug.cgi?id=1959167
17:00:15 <amoloney> I have to drop (right at the interesting part!)
17:00:57 <jwboyer> themayor, that's a product decision.  as the bug says, we do not plan to support aarch64 at this time there
17:01:05 <bstinson> looks like the RHEL maintainers have closed this because they don't plan to support aarch64
17:02:36 <bstinson> if aarch64 is something the community would like to maintain, could we build this in a SIG?
17:03:40 <jwboyer> yeah, that's an interesting idea
17:04:42 <themayor> So just to clarify is this aarch64 in general?
17:05:00 <bstinson> sorry if that was unclear
17:05:21 <bstinson> aarch64 on open-vm-tools is not supported in RHEL
17:06:32 <themayor> Got it ok. Scared me for a sec
17:07:19 <themayor> So what’s the best way to go about it
17:07:29 <themayor> Should this be something done through EPEL?
17:07:47 <themayor> meaning what’s the line of demarcation between what we want to do here and what should be done there?
17:08:54 <jwboyer> it could be done in EPEL, but it would need to be done as a module because EPEL doesn't duplicate RHEL packages
17:09:05 <themayor> Right
17:10:10 <carlwgeorge> https://fedoraproject.org/wiki/EPEL:Packaging#Limited_Arch_Packages
17:10:27 <themayor> So what’s our path of least resistance?
17:10:30 <carlwgeorge> oh scratch that, not allowed for epel8
17:12:09 <bstinson> that package could also be built/maintained as an output of the Virt SIG. provided someone is willing to take that on
17:14:34 <bstinson> to round this out, and since we're 15 minutes over time...themayor: would you like to discuss this more next time?
17:16:03 <themayor> @ezamriy: I think we are comfortable with that
17:16:09 <kkeithley> meta question: re: that package could also be built/maintained as an output of the Virt SIG.    Any ETA for when we'll be able to build packages in CBS for C9S?
17:16:10 <themayor> We can close the issue for now
17:17:13 <bstinson> kkeithley: i don't have a firm ETA for you at this time, but we're close to having what we need to get buildroots enabled
17:19:23 <kkeithley> okay
17:19:35 <bstinson> do we have any other business for today? i think we need amoloney to close out the meeting
17:20:38 <rbowen> Yes, I don't believe she made anyone else a chair.
17:20:46 <rbowen> #endmeeting
17:23:06 <rbowen> #endmeeting
17:23:09 <rbowen> :(
17:24:07 <jwboyer> frowny?
17:30:57 <nirik> FYI, owners of centbot should be able to do 'addchair #centos-meeting libera theirnick'
17:44:44 <Bahhumbug> @addchair rbowen
17:44:44 <centbot> Bahhumbug: (addchair <channel> <network> <nick>) -- Add a nick as a chair to the meeting.
17:45:14 <Bahhumbug> @addchair #centos-meeting rbowen
17:45:14 <centbot> Bahhumbug: (addchair <channel> <network> <nick>) -- Add a nick as a chair to the meeting.
17:45:32 <Bahhumbug> Gimme a second.
17:45:40 <Bahhumbug> 68
17:45:43 <Bahhumbug> networks
17:45:49 <Bahhumbug> @list network
17:45:49 <centbot> Bahhumbug: cmdall, command, connect, disconnect, driver, latency, networks, reconnect, uptime, whois, and whowas
17:46:04 <Bahhumbug> @networks
17:46:04 <centbot> Bahhumbug: libera: tungsten.libera.chat
17:46:25 <Bahhumbug> @addchair #centos-meeting libera rbowen
17:46:25 <centbot> Bahhumbug: Chair added: rbowen on (#centos-meeting, libera).
17:46:41 <rbowen> #endmeeting